Tuesday, January 1, 2013

.NET 4.5 Behaviors

My company made the move to Visual Studio 2012 back in the fall. Since making the move and updating our projects to the .NET 4.5 framework, we had been noticing an error relating to behaviors when building our apps. The error was something along the lines of the following:

The type 'MyType' from assembly 'MyAssembly.Stuff' is built with an older version of the Blend SDK, and is not supported in a Windows Presentation Framework 4 project.

Despite seeing this error, we could still run the app successfully. However, this would also cause issues with loading the window in the XAML designer.

After some research, I found that there is a 4.5 version of System.Windows.Interactivity that needed to be referenced in order to fix the issue. This DLL comes as a part of the Blend + SketchFlow Preview for Visual Studio 2012. As the title indicates, this is a preview version, so we can expect the final version in the near future. According to Microsoft, the final release of this DLL will come as a part of Visual Studio 2012 Update 2.

No comments:

Post a Comment